This solution is used within the U.S.. It combines standards associated with US: TCIP with those for I–M: Secure Wireless Internet (ITS). The US: TCIP standards include upper–layer standards required to implement transit–related communications. The I–M: Secure Wireless Internet (ITS) standards include lower–layer standards that support secure communications between two entities, either or both of which may be mobile devices, but they must be stationary or only moving within wireless range of a single wireless access point (e.g., a parked car). Security is based on X.509 or IEEE 1609.2 certificates. A non–mobile (if any) endpoint may connect to the service provider using any Internet connection method.
| Level | DocNum | FullName | Description |
|---|
| Mgmt | IETF RFC 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks | This standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture. |
|---|
| Mgmt | IETF RFC 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity. |
|---|
| Mgmt | IETF RFC 3413 | Simple Network Management Protocol (SNMP) Applications | This standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys. |
|---|
| Mgmt | IETF RFC 3414 | User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3) | This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model. |
|---|
| Mgmt | IETF RFC 3415 | View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP. |
|---|
| Mgmt | IETF RFC 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the message structure and protocol operations used by SNMPv3. |
|---|
| Mgmt | IETF RFC 3418 | Management Information Base (MIB) for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the MIB to configure and manage an SNMP entity. |
|---|
| Mgmt | IETF RFC 4293 | Management Information Base for the Internet Protocol (IP) | This standard (RFC) defines the MIB that manages an IP entity. |
|---|
| Security | IETF RFC 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile | This standard (RFC) defines how to use X.509 certificates for secure communications over the Internet. |
|---|
| Security | IETF RFC 8446 | The Transport Layer Security (TLS) Protocol | This standard (RFC) specifies Version 1.3 of the Transport Layer Security (TLS) protocol. The TLS protocol provides communications security over the Internet. The protocol allows client/server applications to communicate in a way that is designed to prevent eavesdropping, tampering, or message forgery. |
|---|
| ITS Application Entity | APTA TCIP–S–001 Vol 2 | Transit Communications Interface Profiles – TCIP Data and Dialog Definitions | This standard defines the data concepts used by the TCIP standard. |
|---|
| Facilities | W3C XML | Extensible Markup Language (XML) 1.0 (Fifth Edition) | This standard defines a generic markup language that can be used to share customizable information by using start and stop tags within the text. |
|---|
| Facilities | APTA TCIP–S–001 Vol 2 | Transit Communications Interface Profiles – TCIP Data and Dialog Definitions | This standard defines the data concepts used by the TCIP standard. |
|---|
| TransNet | IETF RFC 4291 | IP Version 6 Addressing Architecture | This standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses. |
|---|
| TransNet | IETF RFC 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification | This standard (RFC) defines the control messages to manage IPv6. |
|---|
| TransNet | IETF RFC 8200 | Internet Protocol, Version 6 | This document specifies version 6 of the Internet Protocol (IPv6). |
|---|
| TransNet | IETF RFC 9293 | Transmission Control Protocol | This document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168. |
|---|
| Access | 3GPP Network | 3GPP Cellular Communications Network | This proxy standard represents a variety of 3GPP releases and underlying standards and technologies that rely upon cellular base stations for connectivity, including 3G, 4G, and the evolving 5G technologies. |
|---|
Multiple significant and minor issues. For existing deployments, the chosen solution is likely deficient in security or management capabilities, and the issues should be reviewed and upgrades developed as needed. Some solutions in this category may also be becoming obsolete from an interoperability perspective and if this is the case, then upgrades should be planned as soon as possible. For new deployments, the solution may be viable for pilots when applied to the triples it supports; such pilot deployments should consider a path to addressing these issues as a part of their design activities. The solution does not provide sufficient interoperability, management, and security to enable proper, full–scale deployment without additional work.
| Issue | Severity | Description | Associated Standard | Associated Triple |
|---|
| Encoding rules not defined | High | The standards do not unambiguously define which set of encoding rules to use. | (None) | (All) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | (All) |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | DARTS Dispatch Center=>transit vehicle operator information=>DARTS Demand Response Vehicles |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | Delta HRA Transportation Dispatch Center=>transit vehicle operator information=>Delta HRA Demand Response Vehicles |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | MATA Dispatch Center=>transit vehicle operator information=>MATA Trolleys |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | MATA Dispatch Center=>transit vehicle operator information=>MATA Paratransit Vehicles |
|---|
| Data not fully defined (medium) | Medium | Some of the data elements for this information flow are not fully defined. | (None) | MATA Dispatch Center=>transit vehicle operator information=>MATA Fixed–Route Vehicles |
|---|
| Out of date (medium) | Medium | The standard includes normative references to other standards that have been subject to significant changes that can impact interoperability or security of systems and the industry has not specified if and how these updates should be implemented for deployments of this standard. | TCIP – Data | (All) |
|---|
| Secure data access not provided | Medium | The solution does not define rules on how the application entity authenticates requests to accept or provide data. | (None) | (All) |
|---|
| Data not defined in standard format | Low | The definition of data concepts should conform to ISO 14817–1 to promote reuse among ITS. | TCIP – Data | (All) |
|---|
| Source | Destination | Flow |
|---|
| DARTS Demand Response Vehicles | DARTS Dispatch Center | alarm notification |
|---|
| DARTS Demand Response Vehicles | DARTS Dispatch Center | demand response passenger and use data |
|---|
| DARTS Demand Response Vehicles | DARTS Dispatch Center | transit vehicle conditions |
|---|
| DARTS Dispatch Center | DARTS Demand Response Vehicles | alarm acknowledge |
|---|
| DARTS Dispatch Center | DARTS Demand Response Vehicles | transit vehicle operator information |
|---|
| Delta HRA Demand Response Vehicles | Delta HRA Transportation Dispatch Center | alarm notification |
|---|
| Delta HRA Demand Response Vehicles | Delta HRA Transportation Dispatch Center | demand response passenger and use data |
|---|
| Delta HRA Demand Response Vehicles | Delta HRA Transportation Dispatch Center | transit vehicle conditions |
|---|
| Delta HRA Transportation Dispatch Center | Delta HRA Demand Response Vehicles | alarm acknowledge |
|---|
| Delta HRA Transportation Dispatch Center | Delta HRA Demand Response Vehicles | transit vehicle operator information |
|---|
| MATA Dispatch Center | MATA Fixed–Route Vehicles | alarm acknowledge |
|---|
| MATA Dispatch Center | MATA Fixed–Route Vehicles | fare management information |
|---|
| MATA Dispatch Center | MATA Fixed–Route Vehicles | transit vehicle operator information |
|---|
| MATA Dispatch Center | MATA Paratransit Vehicles | transit vehicle operator information |
|---|
| MATA Dispatch Center | MATA Trolleys | alarm acknowledge |
|---|
| MATA Dispatch Center | MATA Trolleys | fare management information |
|---|
| MATA Dispatch Center | MATA Trolleys | transit vehicle operator information |
|---|
| MATA Fixed–Route Vehicles | MATA Dispatch Center | alarm notification |
|---|
| MATA Fixed–Route Vehicles | MATA Dispatch Center | fare collection data |
|---|
| MATA Fixed–Route Vehicles | MATA Dispatch Center | transit vehicle conditions |
|---|
| MATA Fixed–Route Vehicles | MATA Dispatch Center | transit vehicle loading data |
|---|
| MATA Paratransit Vehicles | MATA Dispatch Center | demand response passenger and use data |
|---|
| MATA Trolleys | MATA Dispatch Center | alarm notification |
|---|
| MATA Trolleys | MATA Dispatch Center | fare collection data |
|---|
| MATA Trolleys | MATA Dispatch Center | transit vehicle loading data |
|---|