This solution is used within the U.S.. It combines standards associated with US: NTCIP Signal System Masters with those for I–F: SNMPv3/TLS. The US: NTCIP Signal System Masters standards include upper–layer standards required to implement center–to–field signal–system master communications. The I–F: SNMPv3/TLS standards include lower–layer standards that support secure center–to–field and field–to–field communications using simple network management protocol (SNMPv3); implementations are strongly encouraged to use the TLS for SNMP security option for this solution to ensure adequate security.
| Level | DocNum | FullName | Description |
|---|
| Mgmt | NTCIP 1201 | NTCIP Global Object (GO) Definitions | This standard defines SNMP objects (data elements) used by a wide range of field devices like time and versioning information. |
|---|
| Mgmt | IETF RFC 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks | This standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture. |
|---|
| Mgmt | IETF RFC 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity. |
|---|
| Mgmt | IETF RFC 3413 | Simple Network Management Protocol (SNMP) Applications | This standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys. |
|---|
| Mgmt | IETF RFC 3414 | User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3) | This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model. |
|---|
| Mgmt | IETF RFC 3415 | View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP. |
|---|
| Mgmt | IETF RFC 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the message structure and protocol operations used by SNMPv3. |
|---|
| Mgmt | IETF RFC 3418 | Management Information Base (MIB) for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the MIB to configure and manage an SNMP entity. |
|---|
| Mgmt | IETF RFC 4293 | Management Information Base for the Internet Protocol (IP) | This standard (RFC) defines the MIB that manages an IP entity. |
|---|
| Security | IETF RFC 6353 | Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines how to use the TLS authentication service to provide authentication within the access control mechanism of SNMP. |
|---|
| ITS Application Entity | NTCIP 1202 | NTCIP Object Definitions for ASC | This standard defines SNMP objects (data elements) for a center to control a traffic signal and its interface with connected vehicles. |
|---|
| ITS Application Entity | NTCIP 1210 | NTCIP Objects for Signal System Masters | This standard defines SNMP objects (data elements) for monitoring and controlling signal system master controllers. |
|---|
| Facilities | NTCIP 1202 | NTCIP Object Definitions for ASC | This standard defines SNMP objects (data elements) for a center to control a traffic signal and its interface with connected vehicles. |
|---|
| Facilities | NTCIP 1210 | NTCIP Objects for Signal System Masters | This standard defines SNMP objects (data elements) for monitoring and controlling signal system master controllers. |
|---|
| Facilities | IETF RFC 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks | This standard (RFC) defines the basic architecture for SNMPv3 and includes the definition of information objects for managing the SNMP entity's architecture. |
|---|
| Facilities | IETF RFC 3412 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that assists in managing the message processing and dispatching subsystem of an SNMP entity. |
|---|
| Facilities | IETF RFC 3413 | Simple Network Management Protocol (SNMP) Applications | This standard (RFC) includes MIBs that allow for the configuration and management of remote Targets, Notifications, and Proxys. |
|---|
| Facilities | IETF RFC 3414 | User–based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3) | This standard (RFC) contains a MIB that assists in configuring and managing the user–based security model. |
|---|
| Facilities | IETF RFC 3415 | View–based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP) | This standard (RFC) contains a MIB that supports the configuration and management of the View–based access control model of SNMP. |
|---|
| Facilities | IETF RFC 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP) | This standard (RFC) defines the message structure and protocol operations used by SNMPv3. |
|---|
| TransNet | IETF RFC 4291 | IP Version 6 Addressing Architecture | This standard (RFC) defines the addressing architecture of the IP Version 6 (IPv6) protocol. It includes the IPv6 addressing model, text representations of IPv6 addresses, definition of IPv6 unicast addresses, anycast addresses, and multicast addresses, and an IPv6 node's required addresses. |
|---|
| TransNet | IETF RFC 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification | This standard (RFC) defines the control messages to manage IPv6. |
|---|
| TransNet | IETF RFC 8200 | Internet Protocol, Version 6 | This document specifies version 6 of the Internet Protocol (IPv6). |
|---|
| TransNet | IETF RFC 9293 | Transmission Control Protocol | This document specifies the Transmission Control Protocol (TCP). TCP is an important transport–layer protocol in the Internet protocol stack, and it has continuously evolved over decades of use and growth of the Internet. Over this time, a number of changes have been made to TCP as it was specified in RFC 793, though these have only been documented in a piecemeal fashion. This document collects and brings those changes together with the protocol specification from RFC 793. This document obsoletes RFC 793, as well as RFCs 879, 2873, 6093, 6429, 6528, and 6691 that updated parts of RFC 793. It updates RFCs 1011 and 1122, and it should be considered as a replacement for the portions of those documents dealing with TCP requirements. It also updates RFC 5961 by adding a small clarification in reset handling while in the SYN–RECEIVED state. The TCP header control bits from RFC 793 have also been updated based on RFC 3168. |
|---|
| Access | NTCIP 2104 | NTCIP SP–Ethernet | This standard defines the Access Layer for center–to–field communications where the local connection is some variant of Ethernet. |
|---|
One significant or possibly a couple minor issues. For existing deployments, the chosen solution likely has identified security or management issues not addressed by the communications solution. Deployers should consider additional security measures, such as communications link and physical security as part of these solutions. They should also review the management issues to see if they are relevant to their deployment and would require mitigation. For new deployments, the deployment efforts should consider a path to addressing these issues as a part of their design activities. The solution does not by itself provide a fully secure implementation without additional work.
| Source | Destination | Flow |
|---|
| City of Bartlett TOC | City of Bartlett Traffic Signals | signal control commands |
|---|
| City of Bartlett TOC | City of Bartlett Traffic Signals | signal control device configuration |
|---|
| City of Bartlett TOC | City of Bartlett Traffic Signals | signal control plans |
|---|
| City of Bartlett TOC | City of Bartlett Traffic Signals | signal system configuration |
|---|
| City of Bartlett TOC | City of Memphis Traffic Signals | signal control commands |
|---|
| City of Bartlett Traffic Signals | City of Bartlett Rail Notification System | signal control coordination |
|---|
| City of Bartlett Traffic Signals | City of Bartlett TOC | signal fault data |
|---|
| City of Bartlett Traffic Signals | City of Memphis TOC | signal fault data |
|---|
| City of Germantown TOC | City of Germantown Traffic Signals | signal control commands |
|---|
| City of Germantown TOC | City of Germantown Traffic Signals | signal control device configuration |
|---|
| City of Germantown TOC | City of Germantown Traffic Signals | signal control plans |
|---|
| City of Germantown TOC | City of Germantown Traffic Signals | signal system configuration |
|---|
| City of Germantown Traffic Signals | City of Germantown Rail Notification System | signal control coordination |
|---|
| City of Germantown Traffic Signals | City of Germantown TOC | signal fault data |
|---|
| City of Germantown Traffic Signals | City of Memphis TOC | signal fault data |
|---|
| City of Horn Lake TOC | City of Horn Lake Traffic Signals | signal control commands |
|---|
| City of Horn Lake TOC | City of Horn Lake Traffic Signals | signal control device configuration |
|---|
| City of Horn Lake TOC | City of Horn Lake Traffic Signals | signal control plans |
|---|
| City of Horn Lake TOC | City of Horn Lake Traffic Signals | signal system configuration |
|---|
| City of Horn Lake Traffic Signals | City of Horn Lake Rail Notification System | signal control coordination |
|---|
| City of Horn Lake Traffic Signals | City of Horn Lake TOC | signal fault data |
|---|
| City of Memphis TOC | City of Bartlett Traffic Signals | signal control commands |
|---|
| City of Memphis TOC | City of Bartlett Traffic Signals | signal control device configuration |
|---|
| City of Memphis TOC | City of Bartlett Traffic Signals | signal control plans |
|---|
| City of Memphis TOC | City of Bartlett Traffic Signals | signal system configuration |
|---|
| City of Memphis TOC | City of Germantown Traffic Signals | signal control commands |
|---|
| City of Memphis TOC | City of Germantown Traffic Signals | signal control device configuration |
|---|
| City of Memphis TOC | City of Germantown Traffic Signals | signal control plans |
|---|
| City of Memphis TOC | City of Germantown Traffic Signals | signal system configuration |
|---|
| City of Memphis TOC | City of Memphis Traffic Signals | signal control commands |
|---|
| City of Memphis TOC | City of Memphis Traffic Signals | signal control device configuration |
|---|
| City of Memphis TOC | City of Memphis Traffic Signals | signal control plans |
|---|
| City of Memphis TOC | City of Memphis Traffic Signals | signal system configuration |
|---|
| City of Memphis TOC | City of Millington Traffic Signals | signal control commands |
|---|
| City of Memphis TOC | City of Millington Traffic Signals | signal control device configuration |
|---|
| City of Memphis TOC | City of Millington Traffic Signals | signal control plans |
|---|
| City of Memphis TOC | City of Millington Traffic Signals | signal system configuration |
|---|
| City of Memphis TOC | Shelby County Health Department Emissions Sensors | signal control commands |
|---|
| City of Memphis TOC | Shelby County Health Department Emissions Sensors | signal control device configuration |
|---|
| City of Memphis TOC | Shelby County Health Department Emissions Sensors | signal control plans |
|---|
| City of Memphis TOC | Shelby County Health Department Emissions Sensors | signal system configuration |
|---|
| City of Memphis TOC | Shelby County Traffic Signals | signal control commands |
|---|
| City of Memphis TOC | Shelby County Traffic Signals | signal control device configuration |
|---|
| City of Memphis TOC | Shelby County Traffic Signals | signal control plans |
|---|
| City of Memphis TOC | Shelby County Traffic Signals | signal system configuration |
|---|
| City of Memphis TOC | Town of Collierville Traffic Signals | signal control commands |
|---|
| City of Memphis TOC | Town of Collierville Traffic Signals | signal control device configuration |
|---|
| City of Memphis TOC | Town of Collierville Traffic Signals | signal control plans |
|---|
| City of Memphis TOC | Town of Collierville Traffic Signals | signal system configuration |
|---|
| City of Memphis Traffic Signals | City of Memphis Rail Notification System | signal control coordination |
|---|
| City of Memphis Traffic Signals | City of Memphis TOC | signal fault data |
|---|
| City of Millington TOC | City of Millington Traffic Signals | signal control commands |
|---|
| City of Millington TOC | City of Millington Traffic Signals | signal control device configuration |
|---|
| City of Millington TOC | City of Millington Traffic Signals | signal control plans |
|---|
| City of Millington TOC | City of Millington Traffic Signals | signal system configuration |
|---|
| City of Millington Traffic Signals | City of Memphis TOC | signal fault data |
|---|
| City of Millington Traffic Signals | City of Millington Rail Notification System | signal control coordination |
|---|
| City of Millington Traffic Signals | City of Millington TOC | signal fault data |
|---|
| City of Olive Branch TOC | City of Olive Branch Traffic Signals | signal control commands |
|---|
| City of Olive Branch TOC | City of Olive Branch Traffic Signals | signal control device configuration |
|---|
| City of Olive Branch TOC | City of Olive Branch Traffic Signals | signal control plans |
|---|
| City of Olive Branch TOC | City of Olive Branch Traffic Signals | signal system configuration |
|---|
| City of Olive Branch Traffic Signals | City of Olive Branch Rail Notification System | signal control coordination |
|---|
| City of Olive Branch Traffic Signals | City of Olive Branch TOC | signal fault data |
|---|
| CIty of Southaven TOC | City of Southaven Traffic Signals | signal control commands |
|---|
| CIty of Southaven TOC | City of Southaven Traffic Signals | signal control device configuration |
|---|
| CIty of Southaven TOC | City of Southaven Traffic Signals | signal control plans |
|---|
| CIty of Southaven TOC | City of Southaven Traffic Signals | signal system configuration |
|---|
| City of Southaven Traffic Signals | City of Southaven Rail Notification System | signal control coordination |
|---|
| City of Southaven Traffic Signals | CIty of Southaven TOC | signal fault data |
|---|
| City of Southaven Traffic Signals | MDOT Northwest Regional TMC | signal fault data |
|---|
| MDOT CCTV Cameras | MDOT Field Sensors | signal control coordination |
|---|
| MDOT DMS | MDOT Field Sensors | signal control coordination |
|---|
| MDOT Dynamic Lane Assignment Sign | MDOT Field Sensors | signal control coordination |
|---|
| MDOT Field Sensors | MDOT CCTV Cameras | signal control coordination |
|---|
| MDOT Field Sensors | MDOT DMS | signal control coordination |
|---|
| MDOT Field Sensors | MDOT Lane Control DMS | signal control coordination |
|---|
| MDOT Lane Control DMS | MDOT Field Sensors | signal control coordination |
|---|
| MDOT Northwest Regional TMC | City of Southaven Traffic Signals | signal control commands |
|---|
| MDOT Northwest Regional TMC | City of Southaven Traffic Signals | signal control device configuration |
|---|
| MDOT Northwest Regional TMC | City of Southaven Traffic Signals | signal control plans |
|---|
| MDOT Northwest Regional TMC | City of Southaven Traffic Signals | signal system configuration |
|---|
| MDOT Northwest Regional TMC | MDOT Field Sensors | signal control commands |
|---|
| MDOT Northwest Regional TMC | MDOT Traffic Signals | signal control commands |
|---|
| MDOT Northwest Regional TMC | MDOT Traffic Signals | signal control device configuration |
|---|
| MDOT Northwest Regional TMC | MDOT Traffic Signals | signal control plans |
|---|
| MDOT Northwest Regional TMC | MDOT Traffic Signals | signal system configuration |
|---|
| MDOT Traffic Signals | City of Southaven Rail Notification System | signal control coordination |
|---|
| MDOT Traffic Signals | MDOT Northwest Regional TMC | signal fault data |
|---|
| Municipal TOC | Municipal Traffic Signals | signal control commands |
|---|
| Municipal TOC | Municipal Traffic Signals | signal control device configuration |
|---|
| Municipal TOC | Municipal Traffic Signals | signal control plans |
|---|
| Municipal TOC | Municipal Traffic Signals | signal system configuration |
|---|
| Municipal Traffic Signals | Municipal Rail Notification System | signal control coordination |
|---|
| Municipal Traffic Signals | Municipal TOC | signal fault data |
|---|
| Shelby County Health Department Emissions Sensors | City of Memphis TOC | signal fault data |
|---|
| Shelby County TOC | Shelby County Traffic Signals | signal control commands |
|---|
| Shelby County TOC | Shelby County Traffic Signals | signal control device configuration |
|---|
| Shelby County TOC | Shelby County Traffic Signals | signal control plans |
|---|
| Shelby County TOC | Shelby County Traffic Signals | signal system configuration |
|---|
| Shelby County Traffic Signals | City of Memphis TOC | signal fault data |
|---|
| Shelby County Traffic Signals | Shelby County TOC | signal fault data |
|---|
| TDOT CCTV Cameras | TDOT Field Sensors | signal control coordination |
|---|
| TDOT DMS | TDOT Field Sensors | signal control coordination |
|---|
| TDOT Dynamic Lane Assignment Sign | TDOT Field Sensors | signal control coordination |
|---|
| TDOT Field Sensors | TDOT CCTV Cameras | signal control coordination |
|---|
| TDOT Field Sensors | TDOT DMS | signal control coordination |
|---|
| TDOT Field Sensors | TDOT Dynamic Lane Assignment Sign | signal control coordination |
|---|
| TDOT Field Sensors | TDOT Lane Control DMS | signal control coordination |
|---|
| TDOT Lane Control DMS | TDOT Field Sensors | signal control coordination |
|---|
| TDOT Region 4 TMC – Memphis | TDOT Field Sensors | signal control commands |
|---|
| Town of Collierville TOC | Town of Collierville Traffic Signals | signal control commands |
|---|
| Town of Collierville TOC | Town of Collierville Traffic Signals | signal control device configuration |
|---|
| Town of Collierville TOC | Town of Collierville Traffic Signals | signal control plans |
|---|
| Town of Collierville TOC | Town of Collierville Traffic Signals | signal system configuration |
|---|
| Town of Collierville Traffic Signals | City of Memphis TOC | signal fault data |
|---|
| Town of Collierville Traffic Signals | Town of Collierville Rail Notification System | signal control coordination |
|---|
| Town of Collierville Traffic Signals | Town of Collierville TOC | signal fault data |
|---|